1

Topic: SSL Login Issue

Hi All,

Recently I renewed a certificate for one of my Adobe Connect Servers. In doing so, I updated my trusted root certificates using MMC, as well as a pre-built script made by Sun Systems. Nonetheless, whenever I try to access web services I still obtain the same error below:

I/O error: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

Is there anything else I am missing or has anyone else faced this problem?

Thanks again,
Vlad

2

Re: SSL Login Issue

I'm not sure what you are trying to do, but to secure Adobe Connect I would follow this document.

http://kb2.adobe.com/cps/878/cpsid_87809.html

3

Re: SSL Login Issue

Let me better explain then - I have SSL configured on Adobe Connect already. I have followed the documentation above, but now my code that utilizes Web Services fails due to a certicate error. Has anyone seen this behaviour before?

4

Re: SSL Login Issue

Resolved the issue by update the keystore. I do have an Adobe Connect 8.0 question though - regarding Stunnel.exe. Is this installed as a MS Service and runs automatically or you need to invoke it? Reason I ask is because it came installed with our 8.0 package but not as a service, so I need to manually invoke it to have SSL run. This becomes an issue when I log out of the computer and it stops running (no one can then log in). I created an MS Service for it and it still errors out with a 1053 code - any suggestions?

Thank you!

5

Re: SSL Login Issue

hi vklym
did you find how to resolve the 1035 error.. i got the same exact problem..

6

Re: SSL Login Issue

Hi Paraday,

Yes - since stunnel is a native windows service you can simply navigate to the folder where you have breeze\stunnel and execute stunnel -install to install the service. This solved the 1053 for me.

7 (edited by **_DillonHagan_** 2011-09-07 07:22:53)

Re: SSL Login Issue

Same here...Even when gone through the tutorial it didn't help.

8

Re: SSL Login Issue

vklym wrote:

Resolved the issue by update the keystore. I do have an Adobe Connect 8.0 question though - regarding Stunnel.exe. Is this installed as a MS Service and runs automatically or you need to invoke it? Reason I ask is because it came installed with our 8.0 package but not as a service, so I need to manually invoke it to have SSL run. This becomes an issue when I log out of the computer and it stops running (no one can then log in). I created an MS Service for it and it still errors out with a 1053 code - any suggestions?

Thank you!

I have followed the documentation above, but now my code that utilizes Web Services fails due to a certicate error.

9 (edited by **_appypaddy_** 2012-03-01 04:20:01)

Re: SSL Login Issue

I have followed above document,now mostly to clear my doubt.