1 (edited by **_elliotrevan_** 2011-12-05 10:06:52)

Topic: Custom pod with datagrid doesn't record properly

I have created a custom pod that uses a data grid, everything records properly in meeting recordings apart from the date field which uses a custom item renderer to format the date. For some reason in meeting recordings this column is blank. Does anyone know why this happens and if there is a solution?

Elliot

2

Re: Custom pod with datagrid doesn't record properly

Are you handling the events correctly (I think 'caught up' is one of most often missed out ones).

From Connect's perspective, DataGrid is quite irrelevant. Connect would just pass on the recorded events and it's pod's responsibility to render the data correctly.

3

Re: Custom pod with datagrid doesn't record properly

I agree - I can't think of why it wouldn't work in a recording.  You can use the isArchive() function to test whether the pod is being executed in a recording or live meeting.

My only thought here is that the column might fail at certain times of day or certain dates - since it's a date column.  I would expect the data field to show the current date and time - not the date and time that the recording is made.

4 (edited by **_elliotrevan_** 2011-12-12 10:29:57)

Re: Custom pod with datagrid doesn't record properly

Hi,

Thank you for all your responses. I now know that this is not associated with the custom item render.
When I bypass the item render and display the datetime in the original format the recording displays [object Object] as opposed to nothing when watching the recording.

I don't understand how this is a syncing issue, as when the room is in use all participant including ones who join late can see the datetime field for all items. When an item is created a sync message is sent, the message string is describing an object with all the fields and their values. The value for the field in question is the dateChooser.selectedDate which which should be a datetime string. Delta is set to true for all sync message so anyone entering the room late should receive all the sync messages, in the virtual room they do.

The sync message listener then creates the object as described in the sync message.

It looks as though I haven't defined what property to display properly in the recording when [object Object] appears, but it must be receiving something to display that, or else would it not be blank?

Very odd.

5 (edited by **_elliotrevan_** 2011-12-12 11:14:03)

Re: Custom pod with datagrid doesn't record properly

Even weirder you can use the pod in the recording, just pause it and add more items, when you do this the pod works as expected, obviously not syncing but displaying the Date Due field as expected.

I tried converting the column to a string using toLocaleDateString() still no joy. Is is almost as if recordings are unable to handle date info which can't be the case.

Has anyone else used datetime fields in a custom pod data grid and do they get the same recording issues?